OAuth setup for other authentication methods

Home Forums Technical OAuth setup for other authentication methods

This topic contains 2 replies, has 1 voice, and was last updated by  dtopps 1 year, 10 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #678


    This has been available for quite a while but the documentation has not been easily available.

    This is not for the timid and is only aimed at those who administer their own OpenLabyrinth site.


    Contact us if you have problems



    Prompted by a question from Yusuf, I have been exploring again how to set up OAuth authentication on your OLab server.

    I am pleased to say that the process still works just fine for Facebook and Twitter logins, with only tiny changes in the steps needed, which are self-evident.

    It is not so easy for Google+ logins. There are more steps needed now, and I seem to have run into a wee loop of steps where I can go no further. Happy to discuss this further with other groups who are trying to do this.



    I have some further suggestions from Yusuf, for which I am very grateful, where he figured out some problems that lay in his .htaccess file. I am reposting his note here because others may run into this:

    I have done some debugging on home.php on line 60

    public function action_loginOAuthCallback()

    With the issue #104 I have confirmed it is a htacess issue. So I have changed my htacess file as

    Options +FollowSymLinks
    Turn on URL rewriting
    RewriteEngine On
    Protect hidden files from being viewed
    Order Deny,Allow
    Deny From All
    # Redirect Trailing Slashes...
    RewriteRule ^(.*)/$ /$1 [L,R=301]
    Allow any files or directories that exist to be displayed directly
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^ index.php [L]

    With this htacess, I was able to login with Twitter, Facebook and Google+ So I suggest to change htacess file as this.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.